Article delegate-en/4005 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]

Newsgroups: mail-lists.delegate-en

[DeleGate-En] delegate 9.7.7 and io timeout
03 Jul 2008 01:48:00 GMT puuhqbdyi-7pkjwodnwjfr.ml@ml.delegate.org


Hello,

At first, Many thanks for your great product!

Few days ago, I updated delegate from 8.5.9 to 9.7.7.
Then I found that ftp timeout (TIMEOUT=io:0) seems not working correctly.

In delegate log , I could find "poll-TIMEOUT" error.Please see belows,

Log of 8.5.9

07/03 09:03:23.72 [14960] 1+0/6/4: ftp_conndata: connected 
172.31.92.46:47869->172.31.145.174/172.31.145.174:1755 [24](0.0)
07/03 09:03:23.72 [14960] 1+0/6/4: DATA xx.xx.xx.xx:9296 -> 
172.31.92.46:47868 .. 172.31.92.46:47869 -> 172.31.145.174:1755
07/03 09:03:23.78 [14960] 1+0/6/4: FTP data-relay([23]15554b -> 
[24]10000b) 537b / 1/ (AF) 0.07s (read-EOF)

Log of 9.7.7

07/03 10:01:09.17 [14160] 5+0/6/4: ftp_conndata: connected 
172.31.92.46:47671->172.31.145.174/172.31.145.174:1750 [24](0.0)
07/03 10:01:09.17 [14160] 5+0/6/4: DATA xx.xx.xx.xx:9291 -> 
172.31.92.46:47657 .. 172.31.92.46:47671 -> 172.31.145.174:1750
07/03 10:01:09.17 [14160] 5+0/6/4: FTP data-relay([23]15554b -> 
[24]10000b) 0b / 0/ (0) 0.00s (poll-TIMEOUT)

When I changed timeout value to default(600sec), 9.7.7 also works well.
I'm not sure it's bug or not. "0" does not mean "never timeout" no longer?

Thanks,

---
Atsushi Sato
ALPINE Information System Inc.
TEL: +80-000-00-0003 FAX: +80-000-00-0003
E-Mail:asato@alpine..jp

  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V