Article delegate-en/2881 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
[Reference:<_A2844@delegate-en.ML_>]
Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: CAN'T INSTALL AS A SERVICE ON WINDOWS NT
31 Mar 2005 20:38:36 GMT feedback@delegate.org (Yutaka Sato)
The DeleGate Project


On 02/25/05(22:57) you "Salvatore Tarallo \(starallo\)" <starallo@cisco..> wrote
in <_A2844@delegate-en.ML_>
 |after messing with the registry, I can't install again delegate as a
 |service.

What do you mean by "messing with the registry" ?

 |When executing from the CLI dg.exe -P8080 I'm first notified that the
 |service already exists (even if theres no entry in the registry) asked
 |if I want to remove the service and when I answer yes, it returns an
 |"Error could not delete the service"
 |What can I do to fix it ?

I feel I saw such situation...
I saw it when I started DeleGate while I'm opening a "Service" management
window.  After exited the "Service" tool, the deletion succeeded...

 |I've already tried creating a new service on a different port

Did the new service work ?

 |and then
 |create a duplicate entry in the registry with the 8080 port, removing
 |all the etc directories to no avail.

I don't think just copying registry is enough to make a service.
How about trying this? 1) stop the DeleGate service using "Service" tool,
2) exit the "Service" tool, 3) start DeleGate.

Cheers,
Yutaka
--
  D G   Yutaka Sato <y.sato@delegate.org> http://delegate.org/y.sato/
 ( - )  National Institute of Advanced Industrial Science and Technology
_<   >_ 1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan
Do the more with the less -- B. Fuller

  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V