Article delegate-en/2662 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
[Reference:<_A2653@delegate-en.ML_>]
Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: Problem with PAM authentication
22 Jun 2004 19:40:00 GMT feedback@delegate.org (Yutaka Sato)
The DeleGate Project


On 06/15/04(17:56) you Jehan-Guillaume de Rorthais <p4edabdyi-dyd2yvf2a6xr.ml@ml.delegate.org> wrote
in <_A2653@delegate-en.ML_>
 |Your second more complete test program works on my server (debian r3.0 up-to-date).
 |As Root :
 |    frpa01proxy:/tmp# ./a.out passwd adminjrr deletest
 |    ## pam_authenticate [passwd][adminjrr] = 0
...
 |But, as delegate system user :
 |    delegate@frpa01proxy:/tmp$ ./a.out passwd adminjrr deletest
 |    ## pam_authenticate [passwd][adminjrr] = 7
...
 |I think that the third test failed because of a right issue and that your dgpam
 |program bypass with the suid/sgid bits right ?

Yes.  It is because you need privilege to access password file.
It is the reason why DeleGate do external "dgpam" command under
super user's right.

 |I re-built delegate because I installed new dev packets of pam...But it still
 |doesn't works.

What is recorded in logfile of DeleGate now?
Are you getting "PAM: cannot start" error yet?

Cheers,
Yutaka
--
  D G   Yutaka Sato <y.sato@delegate.org> http://delegate.org/y.sato/
 ( - )  National Institute of Advanced Industrial Science and Technology
_<   >_ 1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan
Do the more with the less -- B. Fuller

  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V