Article delegate-en/2146 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]

Newsgroups: mail-lists.delegate-en

[DeleGate-En] Bug in FTP proxy
04 Mar 2003 02:20:43 GMT "Dameon D. Welch-Abernathy" <plueabdyi-t75q7lvz4njr.ml@ml.delegate.org>


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Using Delegate 8.3.4 on Linux (local end) and FreeBSD (remote end)

I have something set up similar to what is described on
http://www.delegate.org/delegate/ssh/, i.e. I have a local machine
running several specialist delegate proxies and a generalist that
tunnels using the TUNNEL directive:

hosta% delegated -P4269 TUNNEL=tty7:ssh.shio SERVER=delegate
DGROOT=/home/dwelch/delegate
hosta% delegated -P8080 MASTER=127.0.0.1:4269 SERVER=http REMITTABLE=*
DGROOT=/home/dwelch/delegate
hosta% delegated -P2121 MASTER=127.0.0.1:4269 SERVER=ftp
DGROOT=/home/dwelch/delegate
hosta% delegated -P2323 MASTER=127.0.0.1:4269 SERVER=telnet
DGROOT=/home/dwelch/delegate

http and telnet work really well, but ftp (passive or active) seem to
have a problem in that data connections time out and go nowhere.
*However*, if I run delegate from a different host (say hostb) and do
all my FTP connections from through the other host, e.g.:

hostb% delegated -P2121 MASTER=hosta:4269 SERVER=ftp
DGROOT=/home/dwelch/delegate

it works fine. ssh.shio is as the example except I use RES_NS in there
as well.

Am I missing something here? Is this a bug?

- -- PhoneBoy
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1-nr1 (Windows 2000)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQE+ZA40CdClwVl/XSoRAnS7AKDThMp0hMJVLx7bMLI1LZe/mZCmjgCgjY3U
GmTUHI9Yw8I5TgWa2Mp46Uc=
=J5YO
-----END PGP SIGNATURE-----


  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V