Article delegate-en/2007 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]

Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: http URL redirection and SSL
02 Dec 2002 07:10:34 GMT "Blake, Jordan (ISS Atlanta)" <pxadqbdyi-4z7oftawab5r.ml@ml.delegate.org>


Thanks for your help. I actually wasn't attempting to use url redirection at the same time as the tcprelay, but rather as a possible alternative. In any case, what you said below makes sense.
 
To troublehsoot this issue, I started Delegate 8.1.0 Win32 with this command-line (sslway is working fine):
 
< DIV>delegated -v-P500 FCL=sslway ADMIN="test@" PERMIT="*:*:*"
 
It seems that when I connect to any redirected URL that doesn't have a "/" after the hostname, it will try to connect to it using http instead of https and subsequently fail.
 
E.g.
When I type in https://127.0.0.1:500/-_-http://www.yahoo.com Internet Explorer automatically tries to connect as http://127.0.0.1:500/-_-http://www.yahoo.com/ (it replaces the "https" with "http" and adds a "/" at the end). This fails.
 
So instead I type in https://127.0.0.1:500/-_-http://www.yahoo.com/ (with a trailing "/") directly and it works fine first try.
 
Incidentally, the BASEURL switch does not seem to affect this behavior.
 
If I start delegate without the FCL=sslway, everything works fine no matter how the URL is typed (and it will automatically add the "/").
 
--Jordan
 
-----Original Message----- 
From: Yutaka Sato [mailto:feedback@delegate.org] 
Sent: Sat 11/30/2002 7:56 AM 
To: feedback@delegate.org 
Cc: Blake, Jordan (ISS Atlanta) 
Subject: Re: [DeleGate-En] http URL redirection and SSL



	On 11/29/02(18:47) you "Blake, Jordan (ISS Atlanta)" <JBlake@iss.net> wrote
	in <2DF52978DE0D854F9435C7AA7DD51F9853E2F5@atlmaiexcp01.iss.local>
	 |Using DeleGate 8.1.0, SSLWAY works fine for me in CERN (RELAY=proxy) mode,
	 |but I'd like to be able to combine SSL with URL redirection
	 |(RELAY=delegate) using this notation https://delegate/-_-URL
	 |<https://delegate/-_-URL> .
	 |I can administer the proxy using https (https://delegate/-/admin/),
	 |but when I try to use the URL redirection it will work initially for a
	 |couple URLs, but fail after a few sites and then refuse to work after that,
	 |even sometimes after restarting DeleGate.
	 |I can't seem to reliably identify the problem.
	 |Also, URLs keep defaulting back to http:// instead of https:// when
	 |typed into the IExplorer address bar... don't know if that's something
	 |DeleGate has control of though.
	
	If you are chaining DeleGate as tcprelay-DeleGate -> HTTPS-DeleGate
	like describe in <URL:http://www.delegate.org/mail-lists/delegate-en/1981>,
	then you need a parameter
	
	  BASEURL=https://tcprelay-DeleGate
	
	at the HTTPS-DeleGate.  Since RELAY=delegate makes DeleGate visible to
	HTTP clients as it it is a origin server, the URL of DeleGate to be
	shown by itself to client must be the one which clients identify the
	DeleGate.  Clients are seeing the URL (address) of tcprelay-DeleGate as
	if it is the real HTTP-DeleGate server in this case.
	
	Cheers,
	Yutaka
	--
	  @ @ Yutaka Sato <y.sato@delegate.org> http://www.delegate.org/y.sato/
	 ( - ) National Institute of Advanced Industrial Science and Technology (AIST)
	_<   >_ 1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan
	Do the more with the less -- B. Fuller
	


  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V