Article delegate-en/1693 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
[Reference:<_A1689@delegate-en.ML_>]
Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: Delegate spins cpu to 100% on Win2k Server boot
15 Jun 2002 16:05:44 GMT feedback@delegate.org (Yutaka Sato)


Hi,

On 06/13/02(02:10) you Jeff Frost <ppqdabdyi-t7hpmu4bwfxr.ml@ml.delegate.org> wrote
in <Pine.LNX.4.44.0206121009250.20000-00000X@entropy.digitalpipe.net>
 |The fix was switching to +=file to load the configuration.  It seems that 
 |delegate has a problem when it tries to load its config from an http server 
 |which has not yet begun listening on port 80.

I made a case where DeleGate as a service on Win32 spins cpu to 100%.

  1) start DeleGate as a service like this
   > delegated -P9999 ADMIN=ysato@delegate.org
  2) edit the registory of the DeleGate service to remove ADMIN parameter
  3) stop and start the service
  4) delegated.exe starts to spin cpu to 100%

The DeleGate is in infinite loop to get ADMIN parameter interactively
from the console which is not available when running as a service.

So if you are defining the ADMIN parameter in the parameter file which
was not available at the restart time, this was what happened there.

Anyway I'll fix the source of the problem in the next release.

Cheers,
Yutaka
--
  @ @ Yutaka Sato <y.sato@delegate.org> http://www.delegate.org/y.sato/
 ( - ) National Institute of Advanced Industrial Science and Technology (AIST)
_<   >_ 1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan

  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V